文档首页 > > 工具指南> Data Studio数据库集成开发工具> SQL终端管理> 打开并保存SQL脚本

打开并保存SQL脚本

分享
更新时间: 2019/08/09 GMT+08:00

打开SQL脚本

执行以下步骤打开SQL脚本:

  1. 选择“文件 > 打开”。单击工具栏上的“打开”按钮,或在SQL终端页签单击右键,选择“打开”。

    如果SQL终端页签已有SQL脚本,则系统允许用户选择是否进行覆盖或追加至当前SQL脚本后。

  2. 弹出“打开”对话框。
  3. 在“打开”对话框中,选择要导入的SQL文件,单击“打开”。

    系统以文件终端页签的形式打开该文件。

    文件终端页签图标不同于SQL终端页签。如果将鼠标悬停在源文件上,则系统会在文件终端上显示相应的数据库连接。

说明:
  • SQL文件编码类型必须匹配首选项中指定的编码类型。
  • 如果用户对某文件终端进行了编辑,该页签的图标将以脏标志*字符开头。保存该页签的更改后,该标志会消失。
  • 文件终端不支持重命名。一个终端仅对应一个源脚本文件,但一个脚本文件可以在多个终端页签打开。
  • 仅在当前终端类型为SQL终端时,才能执行打开SQL脚本功能。

Data Studio允许用户在SQL终端中打开并保存SQL脚本。系统保存更改后,SQL终端页签自动变更为文件终端页签。

保存SQL脚本

保存”选项会自动将文件终端的内容保存到关联文件。

执行以下步骤保存SQL脚本:

  1. 执行以下任意操作:

    • 从主菜单选择“文件 > 保存”。
    • 按住Ctrl+S。(该操作支持对文件终端内容进行保存。)
    • 单击工具栏上的“保存”按钮,或在“SQL终端”页签中单击右键,选择“保存”。

    弹出“Data Studio安全免责声明 ”对话框。

  2. 单击“确定 ”。

    Data Studio在状态栏显示保存状态。
    说明:
    • Data Studio将脚本保存为SQL文件,并为该文件设置读/写权限。为了保证文件安全,用户必须获取SQL文件所在文件夹的读写权限。
    • 如果文件有修改或关联的文件不存在,将触发“另存为”操作。
      • 在任何情况下,如果源文件保存失败,系统向用户提供“另存为”选项。如果用户选择不另存,则文件终端退回为SQL终端。
      • 对文件终端的更改不会自动保存。

将SQL脚本另存为新文件

可使用“另存为”选项将终端内容保存为新文件。

执行以下步骤另存SQL脚本:

  1. 执行以下任意操作:

    • 选择“文件 > 另存为”。
    • 按住Ctrl+Alt+S。(该操作支持对SQL终端和文件终端内容进行另存。)

    弹出“Data Studio安全免责声明”对话框。

  2. 单击“确定”。

    弹出“另存为”对话框。

  3. 在“另存为”对话框中,选择保存脚本的路径,单击“保存”。
说明:

如果文件终端有修改未保存,则系统允许用户在Data Studio标准退出时选择保存或取消。

分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

跳转到云社区