
# 安装mysql5.7
1. 下载 MySQL Yum Repository 执行
   ```
   wget -i -c http://dev.mysql.com/get/mysql57-community-release-el7-10.noarch.rpm
   ```
   
2. 添加 MySQL Yum Repository 到你的系统 repository 列表中
   ```
   yum localinstall mysql57-community-release-el7-10.noarch.rpm
   ```
   验证下是否添加成功
   ```
   yum repolist enabled | grep "mysql.*-community.*"
   ```
   选择要启用 MySQL 版本
   查看 MySQL 版本，执行
   ```
   yum repolist all | grep mysql
   ```
   
3. 通过 Yum 来安装 MySQL
   ```
   yum -y install mysql-community-server
   ```
   linux安装MySQL时报错：
   图1安装报错   
   ![](https://support.huaweicloud.com/tcrc-education/zh-cn_image_0000001809342885.png)
   原因：MySQL GPG 密钥已过期导致
   解决办法：执行以下命令，解决
   ```
   rpm --import https://repo.mysql.com/RPM-GPG-KEY-mysql-2022
   ```
   启动 MySQL Server
   ```
   systemctl start mysqld.service
   ```
   查看 MySQL Server 状态
   ```
   systemctl status mysqld.service
   ```
   关闭 MySQL Server
   ```
   systemctl stop mysqld.service
   ```
   关闭 MySQL Server
   ```
   systemctl enable mysqld.service
   ```
   经过 grep "password" /var/log/mysqld.log 命令，返回结果最后冒号后面的字符串就是root的默认密码。
   图2默认密码   
   ![](https://support.huaweicloud.com/tcrc-education/zh-cn_image_0000001762429622.png)
   使用此密码登录后，Mysql 会要求第一件作的事就是改root密码，并且是要求强密码。能够经过set password=password('密码')来更改。数据库
   测试是否安装成功
   ```
   Mysql  -u  root  -p
   ```
   修改当前登录用户密码：
   ```
   mysql>SET PASSWORD = PASSWORD('Zretc137!');
   ```
   允许mysql远程访问
   mysql默认是不允许远程访问的.
   ```
   mysql -u root -p xxxx
   mysql>use mysql
   mysql>grant all privileges on *.* to 'root'@'%' identified by 'Zretc137!';
   mysql>flush privileges;
   ```
   mysql增加配置
   ```
   vi /etc/my.cnf
   [mysqld]
   event_scheduler = on
   wait_timeout=2880000
   interactive_timeout =2880000
   max_allowed_packet=10M
   ft_min_word_len=1
   lower_case_table_names=1
   sql_mode =STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
   max_connections=500
   ```
   
 
