
# TaurusDB提供root账号或super权限吗
TaurusDB提供的管理员账号为root账号，具有去除super、file、shutdown和create tablespace后的最高权限。
大部分的云数据库服务平台，都未给root账号提供super权限。因为一旦用户拥有了super权限，就可以执行很多管理性的命令，比如reset master，set global...，kill，reset slave等，这类操作很有可能导致TaurusDB出现不可预知的异常和故障。
对于需要使用super权限的场景，TaurusDB提供了服务化能力，也可以通过其他方法绕过super权限的限制。
- 示例1：有些用户喜欢登录数据库执行如下命令来修改参数，这在TaurusDB是被禁止的，您只能通过TaurusDB界面中的参数修改功能来实现。 **set global** *参数名* **=** *参数值* **;**
  如果您的脚本中包含set global命令导致super缺失，请删除set global命令，通过TaurusDB控制台的参数修改。
  
- 示例2：有些用户执行如下命令报错，这也是因为没有super权限导致的，只需要去除definer='root'关键字即可。 **create definer='root'@'%' trigger(procedure)...**
  如果您缺失super权限，可以使用mysqldump导入数据，请参考[使用mysqldump将数据迁移至TaurusDB](https://support.huaweicloud.com/usermanual-taurusdb/taurusdb_03_0007.html)导入和导出数据。
  
 
