
# 内网方式下ECS无法连接TaurusDB标准版实例的原因
遇到该问题，参考以下步骤排查解决。
1. 先确认弹性云服务器和TaurusDB标准版实例是否在同一个虚拟私有云下。 
   - 如果在，执行[2]。
   
   - 如果不在，需要重新创建弹性云服务器实例，使之和TaurusDB标准版实例在同一个虚拟私有云下。
   
   
   
   
2. 检查弹性云服务器实例的安全组配置规则是否满足要求。
3. 在弹性云服务器上，测试是否可以正常连接到TaurusDB标准版实例地址的端口。 
   TaurusDB标准版的默认端口为3306。
   ```
   telnet <连接地址> {端口号}
   ```
   - 如果可以通信，说明网络是正常的。
   
   - 如果端口不通，请联系售后技术支持协助排查。
   
   
   
   
4. 用户最初使用非SSL连接方式，正常，之后为提高安全性，用户企业更换为SSL方式，因此登录方式应切换为SSL登录方式，否则会报错： 
   mysql: \[Warning\] Using a password on the command line interface can be insecure.
   ERROR 2026 (HY000): SSL connection error: protocol version mismatch
   此时，先确认采用的连接方式是非SSL连接还是SSL连接。
   如果是采用SSL连接，是否开启SSL。
   
   
 
