
# TaurusDB标准版开启GTID后有哪些限制
TaurusDB标准版实例默认开启GTID且不支持关闭，主备关系的建立等功能均依赖GTID。如果关闭GTID，会对整个TaurusDB标准版的功能（比如备份恢复、主备倒换）受到影响甚至无法运行。
社区版MySQL开启GTID后，如下三种语句执行会报错：
- 使用select语句建表（create table...select）会报错。
- 如果在一个事务中同时处理支持事务的引擎（InnoDB）和不支持事务的引擎（MyISAM）会报错。
- 显式事务中创建临时表（create temporary table）会报错。
为了放开社区版的这些约束，TaurusDB标准版对MySQL内核进行了改造，以支持这些语句。
