
# 迁移演练失败，提示错误码SMS.3805
#### 问题描述
在使用迁移演练功能时，演练状态为失败，错误码提示为：SMS.3805 源端连接目的端22端口发生错误，连接超时**。**
#### 问题分析
迁移演练功能旨在预先检验整体迁移流程，确保主机迁移服务在数据面及业务面的全流程畅通性，同时验证网络环境的稳定性及连通性。通过迁移演练，可以提前发现并解决可能阻塞实际迁移流程的问题，从而提高一次性迁移的成功率。
该错误码通常出现在迁移过程中源端与目的端的连通性异常。具体表现为源端主机无法与目的端主机建立传输数据所需的网络连接。常见原因是访问目的端主机的22端口时发生超时，导致OpenSSH报错"connect timeout"。
#### 解决方案
1. 测试源端主机到目的端主机的网络连通性。 
   - 源端为Windows主机，请在源端主机使用Telnet工具执行如下命令进行测试。
     ```
     telnet {目的端IP地址} {22端口}
     ```
     例如，目的端IP地址为192.168.1.x，则输入命令：
     ```
     telnet 192.168.1.x 22
     ```
     如果提示无法打开连接，则代表网络不通，需要按照[步骤2.]进一步排查网络配置、防火墙设置和SMS-Agent版本。
     
   
   - 源端为Linux主机，请在源端主机使用SSH工具执行如下命令进行测试。
     ```
     ssh -p {端口} {用户名}@{目的端IP地址}
     ```
     例如，目的端IP地址为192.168.1.x，则输入命令：
     ```
     ssh -p 22 root@192.168.1.x
     ```
     如果报错Connection refused或超时，则代表网络不通，需要按照[步骤2.]进一步排查网络配置、防火墙设置和SMS-Agent版本。
     
   
   
   
   
2. 排查网络配置、防火墙设置和SMS-Agent版本。
   
   - 检查源端到目的端的网络是否配置正确。 请检查目的端IP地址是否发生改变，确保目的端配置中的主机与实际目的端为同一台主机。
     为了正常迁移，目的端主机需要处于源端网络的可访问范围内，关于如何正确配置网络请参考[常见网络场景下的网络配置要求和方法](https://support.huaweicloud.com/bestpractice-sms/sms_07_0001.html)。
     
   
   - 检查源端到目的端的连接是否被防火墙、安全组、ACL规则以及安全软件拦截。 请检查源端和目的端的防火墙、ACL规则和安全组设置，确保目的端对源端放通相应端口（Windows放通：22，8899，8900端口；Linux文件级迁移放通：22端口；Linux块迁移放通：22，8900端口）后重试迁移演练功能。
     请检查源端是否存在安全软件拦截，如果存在，则关闭安全软件相关限制后重试迁移演练功能。
     
   
   - 检查SMS-Agent版本。 在SMS控制台的服务器迁移页面，单击源端服务器名称，在任务详情的"源端信息"页签查看源端服务器所安装的SMS-Agent版本。要求安装的SMS-Agent版本必须为25.5.0及以上。如果SMS-Agent版本不满足要求，请在源端[下载并安装最新的SMS-Agent](https://support.huaweicloud.com/qs-sms/sms3_02_0004.html)，然后重新创建任务。
     
   
   
   
   
 
