# 迁移Agent与主机迁移服务自动断开连接时，如何重新建立连接？
#### 问题描述
迁移过程中报错：SMS.6603 源端到服务端失去连接。迁移实时状态显示连接断开，导致大部分操作无法进行。
图1断开连接   
![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0276141316.png "点击放大")
#### 问题原因
- 源端Agent停止运行。
- 源端Agent长时间不操作（默认为30天，可通过config/g-property.cfg的heartmonitorday参数配置），导致Agent主动与服务断开连接。
- 源端Agent与SMS服务网络连接异常。
- 系统被注销或退出了远程登录（部分机器远程登录退出会自动注销），导致SMS-Agent-Py3/SMS-Agent-Py2进程退出。
- 当源端时间与标准时间相差超过15分钟时，会导致AK/SK权鉴失败。例如：源端NTP时间服务器配置错误。
 
#### 源端服务器为Windows操作系统（Windows Server 2019/Windows Server 2016/Windows Server 2012/Windows 10/Windows 8.1）时
1. 登录源端服务器，在右下角寻找Agent图标，检查Agent是否正常运行。 
   - 如果Agent已经退出，请重启Agent。
   
   - 如果Agent正常运行，请执行[2]。
   
   
   
   
2. 在Agent操作界面，检查是否可以单击"启动"按钮。
   
   - 如果可以启动，表示Agent主动与sms服务断开连接，请单击"启动"，重新连接sms服务。
   
   - 如果不能启动，请执行[3]。
   
   
   ![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0276140034.png "点击放大")
   
   
3. 在cmd中执行**telnet sms.cn-north-4.myhuaweicloud.com 443** ，检查源端服务器与服务接口的连通性。
   
   - 如果不能连通，请检查是否配置错误的dns，导致**sms.cn-north-4.myhuaweicloud.com**无法解析；是否设置了防火墙导致域名无法访问。
   
   - 如果可以连通，并且正在数据传输阶段。请检查源端出口带宽，如果带宽低于10Mbps，可能是数据传输占满带宽，导致Agent与sms服务连接超时，请提高源端出口带宽到10Mbps以上，再继续迁移。 ![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0276140036.png "点击放大")
     
   
   
   
   
4. 处理完成后，大约等待1分钟以后，登录目的端管理控制台。
5. 单击"服务列表"，选择"迁移 \> 主机迁移服务"。 
   进入"主机迁移服务"页面。
   
   
6. 在左侧导航树中，选择"服务器迁移"。 
   在"迁移实时状态"列查看该源端的连接状态。
   
   
 
#### 源端服务器为Windows操作系统（Windows Server 2008/Windows 7）时
1. 登录源端服务器，查找SMSAgentDeploy.exe进程，检查Agent是否正常运行。 
   - 如果SMSAgentDeploy.exe进程不存在，请重启Agent后执行[2]。
     ![](https://support.huaweicloud.com/sms_faq/public_sys-resources/warning_3.0-zh-cn.png)
     重启Agent需要重新迁移。
     
   
   - 如果SMSAgentDeploy.exe进程存在，请执行[2]。
   
   
   
   
2. 在cmd中执行**telnet sms.cn-north-4.myhuaweicloud.com 443** ，检查源端服务器与服务接口的连通性。
   
   - 如果不能连通，请检查是否配置错误的dns，导致**sms.cn-north-4.myhuaweicloud.com**无法解析；是否设置了防火墙导致域名无法访问。
   
   - 如果可以连通，并且正在数据传输阶段。请检查源端出口带宽，如果带宽低于10Mbps，可能是数据传输占满带宽，导致Agent与sms服务连接超时，请提高源端出口带宽到10Mbps以上，再继续迁移。 ![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0285646644.png "点击放大")
     
   
   
   
   
3. 处理完成后，大约等待1分钟以后，登录目的端管理控制台。
4. 单击"服务列表"，选择"迁移 \> 主机迁移服务"。 
   进入"主机迁移服务"页面。
   
   
5. 在左侧导航树中，选择"服务器迁移"。 
   在"迁移实时状态"列查看该源端的连接状态。
   
   
 
#### 源端服务器为Linux操作系统时
1. 使用PuTTY或者SSH客户端，登录待迁移的源端服务器。
2. 执行**ps -ef \| grep -v grep \| grep linuxmain** 检查Agent是否正常运行。
   
   - 如果没有linuxmain进程，请重新启动Agent。
   
   - 如果有linuxmain进程，请执行[3]。
     ![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0276140040.png "点击放大")
     
   
   
   
   
3. 在cmd中执行**telnet sms.cn-north-4.myhuaweicloud.com 443** ，检查源端服务器与服务接口的连通性。
   
   - 如果不能连通，请检查是否配置错误的dns，导致**sms.cn-north-4.myhuaweicloud.com**无法解析；是否设置了防火墙导致域名无法访问。
   
   - 如果可以连通，并且正在数据传输阶段。请检查源端出口带宽，如果带宽低于10Mbps，可能是数据传输占满带宽，导致Agent与sms服务连接超时，请提高源端出口带宽到10Mbps以上，再继续迁移。 ![](https://support.huaweicloud.com/sms_faq/zh-cn_image_0285646625.png "点击放大")
     
   
   
   
   
4. 处理完成后，大约等待1分钟以后，登录目的端管理控制台。
5. 单击"服务列表"，选择"迁移 \> 主机迁移服务"。 
   进入"主机迁移服务"页面。
   
   
6. 在左侧导航树中，选择"服务器迁移"。 
   在"迁移实时状态"列查看该源端的连接状态。
   
   
 
