应用管理与运维平台 ServiceStage应用管理与运维平台 ServiceStage

文档首页> 应用管理与运维平台 ServiceStage> 常见问题> Java SDK问题> 连接服务中心提示“Version validate failed”
更新时间:2021/06/16 GMT+08:00
分享

连接服务中心提示“Version validate failed”

开发者可以直接使用公有云提供的服务中心进行开发工作。使用服务中心,开发者需要先注册帐号,并在"我的凭据”里面生成AK/SK信息用于访问认证控制。如何接入公有云请参考应用接入微服务引擎

异常消息

{"errorCode":"400001","errorMessage":"Invalid parameter(s)","detail":"Version validate failed, rule: {Length: 64,Length: ^[a-zA-Z0-9_\-.]*$}"}

问题原因

使用了新版本的SDK,却连接服务中心老版本的SDK。

排查方法

检查服务中心的版本。可以从公有云官网下载最新版本的服务中心,或者从ServiceComb官网下载最新版本的服务中心。

分享:

Java SDK问题 所有常见问题

more