
# 切换后，容灾端虚拟机未正常拉起如何处理？
#### 问题原因
BRS异步复制具备崩溃一致性，切换时内存中的数据可能会丢失，在容灾站点可能需要利用应用或文件系统的崩溃修复功能进行修复，大多数情况下可以将数据恢复到一致状态并正常使用。
#### 处理建议
示例：切换后容灾机器启动失败，发生XFS异常（LSN校验失败），OS进入紧急模式。
![](https://support.huaweicloud.com/sdrs_faq/zh-cn_image_0000002018400056.png "点击放大")
修复手段：执行journalctl命令，确认xfs文件系统异常报错；在OS的emergency mode下，使用xfs_repair命令进行修复。
操作步骤示例如下：
1. 查看/dev/mapper目录下的根文件系统，如rhel-root，则执行如下命令： 
   ```
   xfs_repair /dev/mapper/rhel-root
   ```
   如果出现报错，查看报错原因，或者直接执行：
   ```
   xfs_repair –L /dev/mapper/rhel-root
   ```
   查看回显信息，如下图示例：
   ![](https://support.huaweicloud.com/sdrs_faq/zh-cn_image_0000002187693473.png "点击放大")
   
   
2. 验证是否修复成功。执行如下命令： 
   ```
   mount /dev/mapper/rhel-root /
   ```
   如果挂载成功，说明文件系统已经修复成功，可以进行挂载。
   
   
3. 重启OS。 
   执行*reboot* 命令。重启后，虚拟机正常进入操作系统。
   
   
 
