
# 云容灾网关drm进程启动失败，如何处理？
#### 问题描述
安装部署完容灾网关或者代理客户端后，drm进程启动失败。
#### 根因分析
可能由以下原因导致：
- 原因1：service账号对"/dev/null"目录没有写权限。
- 原因2：本机无法解析hostname域名。
 
#### 处理方法1
赋予service账号对"/dev/null"目录的读写权限。
1. 登录容灾网关或者代理客户端所在服务器。
2. 以"root"用户，执行以下命令，修改"/dev/null"目录权限。 
   **chmod 666 /dev/null**
   
   
3. 执行以下命令，检查"/dev/null"目录权限。 
   **ll /dev/null**
   回显如下类似信息，表示权限设置成功：
   ```
   crw-rw-rw- 1 root root 1, 3 Apr  9 09:21 /dev/null
   ```
   
   
#### 处理方法2
增加"hostname"域名解析。
1. 登录容灾网关或者代理客户端所在服务器。
2. 以"root"用户，执行以下命令，增加hostname域名解析。 
   **echo "127.0.0.1 \`hostname\`" \>\> /etc/hosts**
   
   
3. 执行以下命令，检查hostname域名解析。 
   **ping \`hostname\`**
   回显如下类似信息，表示权限设置成功：
   ```
   PING test-dr (127.0.0.1) 56(84) bytes of data.64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.022 ms
   ```
   
   
