
# 为什么不同版本的数据库会影响服务启动？
#### 问题描述
在创建应用时，指定的数据库类型与实际部署环境使用的数据库存在不匹配情况：
创建应用时指定使用MySQL，但部署时却连接到MariaDB。
虽然指定了MySQL数据库，但未提供具体版本（如5.x或8.x），这可能会导致服务端SDK中的某些Flyway脚本无法正确更新，进而引起服务启动失败。
#### 处理方法
为了确保服务能够顺利启动，请使用以下兼容的数据库版本：
- MySQL 5.x
- MySQL 8.x
- PostgreSQL 13.x
- PostgreSQL 14.x
 
