文档首页 > > SDK参考> Android> 相关资源> SDK下载

SDK下载

分享
更新时间: 2019/06/03 GMT+08:00

SDK源码和API文档

兼容性

  • 版本修订记录信息:ChangeLog
  • 推荐使用的Android系统版本:Android 4.5,5.0,5.1,6.0,7.0,8.0,8.1版本(HTTP/HTTPS协议)。
  • 命名空间:与旧版本(2.1.x)保持兼容,对外的接口都包含在com.obs.services,com.obs.services.model和com.obs.services.exception三个包中。
  • 接口函数:与旧版本(2.1.x)保持兼容。
    说明:

    Android 4.4及以下版本只能使用配置HTTP协议访问OBS服务。

混淆配置

#okhttp
-dontwarn okhttp3.**
-keep class okhttp3.**{*;}

#okio
-dontwarn okio.**
-keep class okio.**{*;}

#sdk
-keep class com.obs.services.** {*;}
-keep class com.obs.log.** {*;}

#java-xmlbuilder
-keep class com.jamesmurty.utils.**{*;}
分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

跳转到云社区