
# 更改RDS for PostgreSQL数据库中表的OWNER报错
#### 问题描述
使用root用户登录并创建my_db数据库，并在该数据库下创建表mytable，然后将表mytable的所有者更改为其他用户**test**时报错。
**ALTER TABLE mytable OWNER TO test;**
![](https://support.huaweicloud.com/rds-pg_faq/zh-cn_image_0000002248942901.png "点击放大")
#### 原因分析
root用户未提权，导致该报错。
![](https://support.huaweicloud.com/rds-pg_faq/public_sys-resources/note_3.0-zh-cn.png)
root用户提权之后，root用户本身具有把表的所有者指定给其他用户的权限。
#### 解决方法
1. 使用test用户登录数据库。
2. 以test用户执行以下授权命令。 **GRANT test TO root;**
   ![](https://support.huaweicloud.com/rds-pg_faq/zh-cn_image_0000002213663184.png "点击放大")
   
3. 使用root用户登录数据库。
4. 以root用户执行更改表mytable所有者的命令，执行结果成功。 **ALTER TABLE mytable OWNER TO test;**
   ![](https://support.huaweicloud.com/rds-pg_faq/zh-cn_image_0000002248783009.png "点击放大")
   
 
