
# 删除RDS for SQL Server主备实例数据库报错
#### 报错现象
手动删除RDS for SQL Server主备实例上的sqlserver数据库，SSMS提示如下报错信息，详见[图1]：
"The database 'xxxx' is enabled for database mirroring.Database mirroring must be removed before you drop the database.错误：3743"
图1报错信息   
![](https://support.huaweicloud.com/rds-mssql_faq/zh-cn_image_0000002250116125.png "点击放大")
#### 原因分析
根据报错信息判断，该RDS for SQL Server实例为主备模式，备库存在镜像，导致主库无法删除。
#### 解决方案
您需要在删除数据库之前，执行以下命令来禁用镜像：
**Use master** **;**
**GO**
**ALTER DATABASE** *\[Database_Name\]* **SET PARTNER OFF;**
**GO**
数据库镜像删除后，您就可以删除数据库。
