文档首页 > > robox容器方案> robox安卓容器 编译指南(鲲鹏920)> 配置编译环境>

安装依赖库和基础组件

安装依赖库和基础组件

分享
更新时间:2021/01/26 GMT+08:00
  1. 安装系统基础依赖库。

    如果安装过程中有获取deb包失败的情况,请根据提示中的网址,手动下载安装,然后重新安装没成功的包。

    1
    2
    3
    apt install dpkg libncurses5-dev libncursesw5-dev libssl-dev cmake cmake-data debhelper dbus google-mock libboost-dev libboost-filesystem-dev libboost-log-dev libboost-iostreams-dev libboost-program-options-dev libboost-system-dev libboost-test-dev libboost-thread-dev libcap-dev libsystemd-dev libdbus-1-dev libegl1-mesa-dev  libgles2-mesa-dev libglib2.0-dev libglm-dev libgtest-dev liblxc1 libproperties-cpp-dev libprotobuf-dev libsdl2-dev libsdl2-image-dev lxc-dev pkg-config protobuf-compiler libboost-filesystem1.62.0 libboost-system1.62.0 docker.io dkms libboost-iostreams1.62.0
    apt install build-essential
    apt install mesa-common-dev
    

  2. 通过链接下载libprocess-cpp3_3.0.1-0ubuntu5_arm64.deblibdbus-cpp5_5.0.0+16.10.20160809-0ubuntu2_arm64.deblibdbus-cpp-dev_5.0.0+16.10.20160809-0ubuntu2_arm64.deb
  3. 安装这三个依赖库。

    dpkg -i libprocess-cpp3_3.0.1-0ubuntu5_arm64.deb
    dpkg -i libdbus-cpp5_5.0.0+16.10.20160809-0ubuntu2_arm64.deb
    dpkg -i libdbus-cpp-dev_5.0.0+16.10.20160809-0ubuntu2_arm64.deb

分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!非常感谢您的反馈,我们会继续努力做到更好!
反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

智能客服提问云社区提问