文档首页 > > 移植指南> 移植libgpg-error

移植libgpg-error

分享
更新时间:2020/07/23 GMT+08:00

介绍

简要介绍

libgpg-error是一个小型库,最初为所有GnuPG组件定义了常见错误值。 其中包括GPG,GPGSM,GPGME,GPG-Agent,libgcrypt,Libksba,DirMngr,Pinentry,SCdaemon。 由于Libgpg-error是所有GnuPG组件的常见依赖项,因此库中添加了更多功能,比如扩展流库(estream),printf实现,锁(互斥)的实现等等。

语言:C

一句话描述:libgcrypt支持库

开源协议:LGPL

建议的版本

建议使用版本为“libgpg-error-1.36”

环境要求

云服务器要求

本文以云服务器KC1实例测试,云服务器配置如表1所示。

表1 云服务器配置

项目

说明

规格

kc1.large.2 | 2vCPUs | 4GB

磁盘

系统盘:高IO(40GB)

操作系统要求

操作系统要求如表2所示。

表2 操作系统要求

项目

说明

下载地址

CentOS

7.6

在公共镜像中已提供。

Kernel

4.14.0-115

在公共镜像中已提供。

配置编译环境

  1. 安装wget工具。

    yum install wget -y

  2. 安装bzip2工具。

    yum install bzip2 -y

  3. 安装依赖库glibc。

    yum install glibc -y

获取源码

获取“libgpg-error-1.36”源码包。

cd /usr/local/src

wget https://www.gnupg.org/ftp/gcrypt/libgpg-error/libgpg-error-1.36.tar.bz2

编译和安装

  1. 解压软件包。

    tar -jxvf libgpg-error-1.36.tar.bz2

  2. 进入libgpg-error的安装目录。

    cd libgpg-error-1.36/

  3. 配置生成Makefile文件。

    ./configure

  4. 编译和安装libgpg-error。

    make && make install

运行和验证

查询libgpg-error版本号。

gpg-error --version

回显信息如下,表示测试libgpg-error安装成功。
gpg-error (libgpg-error) 1.36
Copyright (C) 2019 g10 Code GmbH
License LGPL-2.1-or-later <https://gnu.org/licenses/>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!非常感谢您的反馈,我们会继续努力做到更好!
反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

智能客服提问云社区提问