文档首页 > > 移植指南> 移植Lsyncd

移植Lsyncd

分享
更新时间:2020/06/03 GMT+08:00

介绍

简要介绍

Lsyncd实际上是lua语言封装了inotify和rsync工具,采用了Linux内核(2.6.13及以后)里的inotify触发机制,然后通过rsync去差异同步,达到实时的效果。

语言:Lua、C/C++

一句话描述:数据同步工具

开源协议:GPL-3.0

建议的版本

建议使用git获取最新版本。

环境要求

云服务器要求

本文以云服务器KC1实例测试,云服务器配置如表1所示。

表1 云服务器配置

项目

说明

规格

kc1.large.2 | 2vCPUs | 4GB

磁盘

系统盘:高IO(40GB)

操作系统要求

操作系统要求如表2所示。

表2 操作系统要求

项目

说明

下载地址

CentOS

7.6

在公共镜像中已提供。

Kernel

4.14.0-115

在公共镜像中已提供。

配置编译环境

  1. 安装wget工具。

    yum install wget -y

  2. 安装依赖工具。

    yum install git cmake3 -y

  3. 安装Lua。

    yum install git cmake3 lua lua-devel -y

获取源码

获取lsyncd源码包。

cd /usr/local/src

git clone https://github.com/axkibe/lsyncd.git

编译和安装

  1. 进入目录。

    cd /usr/local/src/lsyncd

    mkdir build

    cd build

  2. 配置生成Makefile。

    cmake3 ../

  3. 编译和安装。

    make

    make install

    如果是下载的其他的版本的源码安装,会出现类似如下错误,是版本问题,在最新的代码中已修复,建议使用git下载最新代码编译。

    CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message):   Could NOT find Lua (missing: LUA_LIBRARIES) Call Stack (most recent call first):   /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)   cmake/FindLua.cmake:114 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)   CMakeLists.txt:9 (find_package)

运行和验证

查看安装的lsyncd版本号

lsyncd -version

[root@ecs-centos-a lsyncd]# lsyncd -version
Version: 2.2.3
分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!非常感谢您的反馈,我们会继续努力做到更好!
反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

智能客服提问云社区提问