文档首页 > > 常见问题> Notebook> 环境配置相关>

如何在Notebook中使用TensorFlow 2.X?

如何在Notebook中使用TensorFlow 2.X?

分享
更新时间:2021/02/26 GMT+08:00

目前Notebook实例已支持TensorFlow 2.1,针对新创建的Notebook实例,可直接选择“Multi-Engine 2.0 (python3)”工作环境创建实例,包含TensorFlow-2.1.0引擎。

针对使用其他工作环境(“Multi-Engine 1.0 (python3 推荐)”“Multi-Engine 1.0 (python2)”)创建的Notebook实例,如需使用TensorFlow 2.X,可参见如下步骤实现。

操作步骤

TensorFlow 2.0可以在Notebook中自行安装和使用,具体的步骤如下:

  1. 创建一个Notebook实例,打开并进入Notebook,选中并进入tensorflow1.13.1的kernel。
  2. 进入kernel页面安装TensorFlow 2.0(GPU版本)。输入如下代码然后单击代码上方的“Run”
    1
    !pip install tensorflow-gpu==2.0.0b1
    
    图1 安装TensorFlow 2.0
  3. 重启Kernel使更新生效。
    图2 重启Kernel
  4. 重启Kernel后,输入如下代码检查安装结果。即可开始使用TensorFlow 2.0了。
    运行如下代码,当回显为“2.0.0-beta1”时,表示安装版本为TensorFlow 2.0。
    1
    2
    import tensorflow as tf
    print(tf.__version__)
    

    运行如下代码,当回显为“True”时,表示安装的是GPU版本。

    1
    print(tf.test.is_gpu_available())
    
    图3 验证安装版本
分享: