
# 深度采集失败，失败原因：源端winrm服务没开启或IP无法连通或端口不通
#### 问题描述
进行主机深度采集时，采集失败，提示：源端winrm服务没开启或IP无法连通或端口不通。
![](https://support.huaweicloud.com/mgc_faq/zh-cn_image_0000002017793046.png "点击放大")
#### 问题分析
可能导致该问题的原因如下：
- 源端主机的IP或端口异常。
- 如果源端为Windows主机，可能未开启WinRM服务。
您可以通过查看MgC Agent（原Edge）的深度采集日志文件确认具体的报错原因，深度采集日志文件的存储路径为：C:\\MgC-Agent\\tools\\plugins\\collectors\\rda-collector-server\\logs\\rda-collector-server\\run.log。
如果非以上两种原因，请排查MgC Agent是否被多个用户同时用于采集，导致MgC Agent侧的WinRM服务与源端断开。
#### 解决方法
- **源端为Linux主机**
  在安装MgC Agent的主机，打开命令行窗口，使用**ping** 命令测试与源端主机的公网IP是否连通；使用**telnet** 命令测试源端主机的端口（默认22端口）是否可以访问。命令格式分别为：**ping {源端主机IP地址}** 、**telnet {源端主机IP地址} {端口}**。
  如果IP或端口不通，请检查源端主机安全组入方向规则中，协议端口号为**TCP：** **22** 和**ICMP：全部**的源地址是否配置为安装MgC Agent主机的公网IP。确认安全组规则配置无误后，重新进行深度采集。
  
- **源端为Windows主机**
  1. 登录源端主机，开启WinRM服务，方法请参考[WinRM服务配置与故障排查](https://support.huaweicloud.com/tg-mgc/mgc_04_2012.html)。开启WinRM服务后重新进行深度采集。如果仍然失败，请执行步骤2.。
  
  2. 在安装MgC Agent的主机，打开命令行窗口，使用**ping** 命令测试与源端主机的公网IP是否连通；使用**telnet** 命令测试源端主机的端口（默认5985端口）是否可以访问。命令格式分别为：**ping {源端主机IP地址}** 、**telnet {源端主机IP地址} {端口}** 。
     如果IP或端口不通，请检查源端主机安全组入方向规则中，协议端口号为**TCP：** **5985** 和**ICMP：全部**的源地址是否配置为安装MgC Agent主机的公网IP。确认安全组规则配置无误后，重新进行深度采集。
     
   
 
