弹性云服务器防火墙配置完成后,为什么网络不通?
问题描述
如果您的云服务器安装完防火墙后,发现网络不通,请根据本章节指导排查原因。常见客户场景示例如下:
在同一个VPC内,客户有三台ECS,业务部署在ECS1和ECS2上,在ECSX上安装了第三方防火墙,从ECS1和ECS2出来的流量,需要通过ECSX的防火墙进行过滤。
排查思路
以下排查思路根据原因的出现概率进行排序,建议您从高频率原因往低频率原因排查,从而帮助您快速找到问题的原因。
如果解决完某个可能原因仍未解决问题,请继续排查其他可能原因。
可能原因 |
处理措施 |
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检查ECS安全组是否已放通 |
解决方法请参考检查ECS安全组是否已放通。 |
检查网卡的“源/目的检查”开关是否关闭 |
解决方法请参考检查网卡的源/目的检查开关是否关闭。 |
检查VPC的自定义路由是否添加正确 |
解决方法请参考检查VPC的自定义路由是否添加正确。 |
检查ECS安全组是否已放通
同一个VPC内的子网网络互通,如果您的业务ECS和防火墙所在的ECS网络不通,可能是因为这些ECS位于不同的安全组导致的。
如果ECS位于不同的安全组内,需要您在这些ECS关联的安全组内添加对端安全组的规则,放通这些安全组的网络。
具体操作请参见添加安全组规则。
检查VPC的自定义路由是否添加正确
请检查业务ECS所在子网的关联路由表中是否添加指向防火墙所在ECS的路由。
防火墙安装完成后,您需要在业务ECS所在子网的关联路由表中,添加下一跳为“云服务器实例”,指向防火墙所在ECS的自定义路由。
具体操作请参见添加自定义路由。
提交工单
如果上述方法均不能解决您的疑问,请提交工单寻求更多帮助。
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