更新时间:2025-08-09 GMT+08:00
ALM-45478 Kudu组件数据均衡失败
告警解释
系统周期性对Kudu组件的数据表进行数据均衡,当检测到数据均衡的接口返回失败,则产生此告警。
当调用Kudu组件的数据均衡接口成功后,告警清除。
告警属性
告警ID |
告警级别 |
是否自动清除 |
---|---|---|
45478 |
重要 |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
对系统的影响
Kudu组件的数据均衡接口调用返回失败,可能是Kudu组件的状态已经异常。
可能原因
Kudu组件的数据表中segment丢失或者副本丢失。
处理步骤
处理Kudu实例异常
- 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”页面,找到“ALM-45478 Kudu组件数据均衡失败”告警。
- 查看告警的“定位信息”,记录主机名与角色名。
- 选择“集群 > 服务 > Kudu > 实例”,单击步骤 2中对应主机名的角色名称,修复该实例,然后查看是否消除各个Kudu实例异常告警。
- 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。
- 是,处理完毕。
- 否,执行步骤 5。
- 在Kudu组件的webUI里查看是否存在segment或者副本缺失。
收集故障信息
- 在FusionInsight Manager首页,单击“运维 > 日志 > 下载”。
- 在“服务”中勾选待操作集群的“Kudu”。
- 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
- 请联系运维人员,并发送已收集的故障日志信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无