更新时间:2024-09-04 GMT+08:00

ALM-45325 Presto服务不可用

本章节仅适用于MRS 3.1.5及之后版本。

告警解释

系统每60秒周期性检测Presto服务状态。当Presto服务不可用时产生该告警;当Presto服务恢复时,告警恢复。

告警属性

告警ID

告警级别

是否自动清除

45325

紧急

告警参数

参数名称

参数含义

ServiceName

产生告警的服务名称。

RoleName

产生告警的角色名称。

HostName

产生告警的主机名。

对系统的影响

Presto无法执行SQL。

可能原因

  • Presto服务不可用可能由Presto Coordinator或Worker自身的进程故障引起。
  • Presto Coordinator和Worker实例间网络通信中断。

处理步骤

检查Coordinator/Worker进程状态。

  1. 在FusionInsight Manager首页,单击“集群 > 待操作集群的名称 > 服务 > Presto > 实例”,在Presto实例列表中,查看所有Coordinator或Worker“运行状态”是否都呈现“未知”状态。

    • 是,执行2
    • 否,执行4

  1. 在Presto实例列表上方,单击“更多 > 重启服务”,重启Coordinator/Worker进程。
  2. 在告警列表中,查看“ALM-45325 Presto服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行4

收集故障信息。

  1. 在FusionInsight Manager首页,单击“运维 > 日志 > 下载”。
  1. 在“服务”中勾选Presto节点信息。
  2. 单击右上角的 设置日志收集的“开始时间”和“结束时间”,分别为告警产生时间的前后10分钟,单击“下载”。
  3. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。