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更新时间:2024-09-04 GMT+08:00

ALM-26052 Storm服务可用Supervisor数量小于阈值

告警解释

系统每60秒周期性检测Supervisor数量,并把实际Supervisor数量和阈值相比较。当检测到Supervisor数量低于阈值时产生该告警。

用户可通过“运维 > 告警 > 阈值设置 > 待操作集群的名称”修改阈值。

当Supervisor数量大于或等于阈值时,告警恢复。

告警属性

告警ID

告警级别

是否自动清除

26052

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

Trigger Condition

系统当前指标取值满足自定义的告警设置条件。

对系统的影响

集群已经存在的任务无法运行;集群可接收新的Storm任务,但是无法运行。

可能原因

集群中Supervisor处于异常状态。

处理步骤

检查Supervisor状态

  1. 选择“集群 > 待操作集群的名称 > 服务 > Storm > Supervisor”,进入Storm服务管理页面。
  2. 查看“角色”中是否存在状态为故障或者是正在恢复的Supervisor实例。

    • 是,执行3
    • 否,执行5

  3. 勾选状态为故障或者正在恢复的Supervisor角色实例,选择“更多 > 重启实例”,查看是否重启成功。

    • 是,执行4
    • 否,执行5

  4. 等待30秒,检查该告警是否恢复。

    • 是,处理完毕。
    • 否,执行5

      Supervisor重启过程中,业务会出现中断,待Supervisor重启成功后业务恢复。

收集故障信息

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Storm”和“ZooKeeper”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。