更新时间:2024-11-29 GMT+08:00
用户修改域名后无法登录MRS Manager页面
问题现象
用户修改域名后,通过console页面无法登录MRS Manager页面,或者登录MRS Manager页面异常。
问题原因
用户修改域名后,没有刷新executor用户的keytab文件,导致executor进程认证失败后不断循环认证,导致了acs进程内存溢出。
解决方案
- 重启acs进程。
- 替换executor用户的keytab文件。
- 登录MRS Manager页面,选择“系统 > 用户”,在executor用户所在的“操作”列,单击“下载认证凭据”,解压后获取keytab文件。
- 使用root用户登录主管理节点,将获取的keytab替换“/opt/executor/webapps/executor/WEB-INF/classes/user.keytab”文件。
- 替换knox用户的keytab和conf文件。
- 登录MRS Manager页面,选择“系统 > 用户”,在knox用户所在的“操作”列,单击“下载认证凭据”,解压后获取keytab和conf文件。
- 使用root用户登录主管理节点,将获取的keytab替换“/opt/knox/conf/user.keytab”文件。
- 修改/opt/knox/conf/krb5JAASLogin.conf中的principal的值,把域名修改为更改后的域名。
- 将获取的krb5.conf 替换“/opt/knox/conf/krb5.conf”文件。
- 备份原有客户端目录
mv {客户端目录} /opt/client_init
- 重新安装客户端。
- 使用root用户登录主备管理节点,执行如下命令,重启knox进程。
su - omm
ps -ef | grep gateway | grep -v grep (查找knox进程PID)
kill -9 PID(PID替换为实际的ID,结束knox进程)
/opt/knox/bin/restart-knox.sh (启动knox进程)
- 使用root用户登录主备管理节点,执行如下命令,重启executor进程。
su - omm
netstat -anp |grep 8181 |grep LISTEN (查找executor进程PID)
kill -9 PID(PID替换为实际的ID,结束executor进程)
/opt/executor/bin/startup.sh (启动executor进程)
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