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更新时间:2024-11-29 GMT+08:00

ALM-43203 Elasticsearch服务存在red状态的索引

告警解释

系统每60秒周期性检测Elasticsearch服务的所有索引状态,当存在red状态的索引时,产生该告警。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

43203

紧急

业务质量告警

Elasticsearch

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

Red状态索引列表

Elasticsearch服务中的red状态索引名称列表。

索引列表受字符长度限制,当内容超过256个字符时仅能显示部分索引名,查询完整索引列表步骤:

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 在线检索 ”。
  2. “检索内容”填写“alarm 43203”,服务选择“OMS > Agent”,文件选择“pluginmonitor”,最低日志级别选择“ERROR”,单击“检索”。
  3. 在检索结果中选择最新的日志,查看Red状态索引的完整列表内容。例如:
    2020-07-10 14:34:00,508 ERROR [monitor_60_1_18_EsMaster] Send alarm 43203. The Elasticsearch cluster has indexes in the Red state, List of indexes in the Red state is [myindex292,myindex200] 

对系统的影响

Elasticsearch部分索引的主分片故障,主分片故障的索引无法正常读写。

可能原因

Elasticsearch实例的主分片缺失。

处理步骤

检查所有实例是否正常。

  1. 在FusionInsight Manager界面,通过“集群 > 待操作集群的名称 > 服务 > Elasticsearch > 实例”查看实例列表运行状态是否良好。

    • 是,执行4
    • 否,执行2

  2. 选择运行状态不是良好的实例,执行“更多”列的“重启实例”操作。

    重启实例需要输入FusionInsight Manager管理员密码。

  3. 实例重启成功后查看告警列表,该告警是否消除。

    • 是,操作结束。
    • 否,执行4

  4. 在FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务 > Elasticsearch”进入Elasticsearch服务页。
  5. 单击服务页中的“资源”进入资源页查看“索引信息”中索引状态为“red”的索引。
  6. 确认该索引是否为无效索引。

    • 是,执行7
    • 否,执行11

  7. 检查Elasticsearch集群是否是安全模式。

    在FusionInsight Manager首页,选择“集群 > 待操作集群的名称 > 服务 > Elasticsearch”,进入Elasticsearch概述页面,单击左侧“配置”进入配置页面。在配置页面右上方搜索框输入“ELASTICSEARCH_SECURITY_ENABLE” ,确认该参数是否可以查询到且参数值为“true”。

    • 是,执行8
    • 否,执行9

  8. 配置安全模式下使用curl命令。
  9. 执行命令curl -XDELETE --tlsv1.2 --negotiate -k -v -u : 'https://ip:httpport/索引名',删除无效索引。

    • “ip”:Elasticsearch集群中任意节点的IP。
    • “httpport”:Elasticsearch实例的HTTP端口,该端口值可以在FusionInsight Manager界面的Elasticsearch服务下,选择该实例的“配置”,选择“全部配置”右上角搜索参数“SERVER_PORT”获取。
    • “索引名”:待删除索引的名称。
    • 如果是普通模式,删除安全认证参数“--tlsv1.2 --negotiate -k -v -u :”,并将“https”修改为“http”。
    • 删除文件为高危操作,在执行操作前请务必确认对应文件是否不再需要。

  10. 等待5分钟查看告警是否恢复。

    • 是,结束操作。
    • 否,执行11

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Elasticsearch”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。