更新时间:2024-11-29 GMT+08:00
ALM-38000 Kafka服务不可用
告警解释
系统按照30秒的周期检测Kafka服务是否可用,当Kafka服务不可用,系统产生此告警。
当Kafka服务恢复正常,告警自动清除。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
38000 |
紧急 |
业务质量告警 |
Kafka |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
对系统的影响
集群无法对外提供Kafka服务,用户无法执行新的Kafka任务。
可能原因
- KrbServer服务故障。(非普通模式集群)
- ZooKeeper服务故障或无响应。
- Kafka服务中Broker实例状态异常。
处理步骤
检查KrbServer服务状态。(普通模式集群跳过此步骤)
- 在FusionInsight Manager管理界面,选择“集群 > 待操作集群的名称 > 服务 > KrbServer”。
- 查看KrbServer服务的运行状态是否为“良好”。
- 参考“ALM-25500 KrbServer服务不可用”的处理步骤进行操作。
- 再次执行2。
检查ZooKeeper服务状态。
- 查看ZooKeeper服务的运行状态是否为“良好”。
- 如果ZooKeeper服务已停止,则启动ZooKeeper服务,否则参考“ALM-13000 ZooKeeper服务不可用”的处理步骤进行操作。
- 再次执行5。
检查Broker实例状态。
- 选择“集群 > 待操作集群的名称 > 服务 > Kafka > 实例”,进入Kafka实例页面。
- 查看“角色”中所有实例是否正常。
- 勾选Broker所有实例,选择“更多 > 重启实例”,查看是否重启成功。
- 选择“集群 > 待操作集群的名称 > 服务 > Kafka”,查看运行状态是否为“良好”。
- 等待30秒,查看告警是否恢复。
- 是,处理完毕。
- 否,执行13。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考