文档首页/ MapReduce服务 MRS/ 用户指南(安卡拉区域)/ 告警参考/ ALM-33005 Containers服务最大并发数超过阈值
更新时间:2024-11-29 GMT+08:00

ALM-33005 Containers服务最大并发数超过阈值

告警解释

系统每5分钟周期性检测服务最大并发数,并把最大并发数和阈值相比较。当检测到服务最大并发数超出阈值范围时产生该告警。

当服务最大并发数小于或等于阈值时,该告警自动清除。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

33005

提示

业务质量告警

Containers

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群或系统名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

应用服务名

产生告警的应用名称。

版本

产生告警的版本。

方法

产生告警的方法。

IP

产生告警的IP。

附加信息

Trigger condition

系统当前指标取值满足自定义的告警设置条件。

对系统的影响

最大并发数过高,会导致服务提供者将拒绝部分调用请求,出现服务调用失败。

可能原因

  • 业务逻辑代码处理时间过长。
  • 业务量太大。

处理步骤

检查业务代码处理时间是否过长。

  1. 在FusionInsight Manager首页,单击“集群 > 服务 > Containers”。
  2. 选择“SGP管理 > 应用服务列表”,单击产生告警的服务名对应的链接,进入该服务的状态页面。
  3. 查看提供者的处理时间是否过长。

    • 是,执行4
    • 否,执行6

  4. 检查用户的上层业务逻辑代码的处理时间是否过长。

    • 是,优化上层业务逻辑代码,执行5
    • 否,执行6

  5. 检查该告警是否清除。

    • 是,处理完毕。
    • 否,执行6

查看业务量是否过大。

  1. 在FusionInsight Manager首页,单击“集群 > 服务 > Containers > SGP管理”,查看“每秒请求数图表”,“响应时间图表”等,数据量是否维持较高水平。

    • 是,执行7
    • 否,执行9

  2. 选择“集群 >服务 > Containers > 业务管理”。选择包含服务的BLU,进入BLU页面并选择“BLU 实例 > 添加实例”添加BLU实例。
  3. 检查该告警是否清除。

    • 是,处理完毕。
    • 否,执行9

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选“Containers”。
  3. 在“主机”中勾选对应角色所在的主机。
  4. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后15分钟,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。