更新时间:2024-11-29 GMT+08:00

ALM-14010 NameService服务异常

告警解释

系统每180秒周期性检测NameService服务状态,当检测到NameService服务不可用时产生该告警。

NameService服务恢复时,告警清除。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

14010

重要

业务质量告警

HDFS

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

NameService名

产生告警的NameService名称。

对系统的影响

无法为基于该NameService服务的HBase和MapReduce等上层部件提供服务。用户无法读写文件。

可能原因

  • KrbServer服务异常。
  • JournalNode节点故障。
  • DataNode节点故障。
  • 磁盘容量不足。
  • NameNode节点进入安全模式。

处理步骤

检查KrbServer服务状态。

  1. 在FusionInsight Manager首页,选择“集群 > 服务”。
  2. 查看KrbServer服务是否存在。

    • 是,执行3
    • 否,执行6

  3. 单击“KrbServer”。
  4. 单击“实例”。在KrbServer管理页面,选择故障实例,选择“更多 > 重启实例”。查看实例能否成功启动。

    • 是,执行5
    • 否,执行24

  5. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行6

检查JournalNode实例状态。

  1. 在FusionInsight Manager首页,选择“集群 > 服务”。
  2. 选择“HDFS > 实例”。
  3. 在实例页面中,查看JournalNode的“运行状态”是否为“良好”。

    • 是,执行11
    • 否,执行9

  4. 选择故障的JournalNode,选择“更多 > 重启实例”。查看JournalNode能否成功启动。

    • 是,执行10
    • 否,执行24

  5. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行11

检查DataNode实例状态。

  1. 在FusionInsight Manager首页,选择“集群 > 服务 > HDFS”。
  2. 单击“实例”查看所有DataNode节点的“运行状态”是否为“良好”。

    • 是,执行15
    • 否,执行13

  3. 单击“实例”。在DataNode管理页面,选择故障DataNode,选择“更多 > 重启实例”。查看DataNode能否成功启动。

    • 是,执行14
    • 否,执行15

  4. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行15

检查磁盘状态。

  1. 在FusionInsight Manager首页,选择“主机”。
  2. 在“磁盘”列,检查磁盘空间是否不足。

    • 是,执行17
    • 否,执行19

  3. 对磁盘进行扩容。
  4. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行19

检查NameNode节点是否进入安全模式。

  1. 在FusionInsight Manager首页,选择“集群 > 服务 > HDFS”。
  2. 在HDFS“概览”的基本信息区域(或HDFS“概览”中“NameService概述”区域)查看“安全模式”参数值是否为“ON”。

    “ON”表示安全模式已打开。

    • 是,执行21
    • 否,执行24

  3. root用户登录客户端。执行cd命令进入客户端安装目录,然后执行source bigdata_env。如果集群采用安全版本,要进行安全认证,执行kinit hdfs命令,按提示输入密码(向MRS集群管理员获取密码)。如果集群采用非安全版本,需使用omm用户登录并执行命令,请确保omm用户具有客户端执行权限。
  4. 执行hdfs dfsadmin -safemode leave
  5. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行24

收集故障信息。

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的如下节点信息。

    • ZooKeeper
    • HDFS

  3. 单击右上角的编辑按钮设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。