更新时间:2024-11-29 GMT+08:00
ALM-12192 主机负载超过阈值
告警解释
系统每30秒周期性检测平均负载,并把实际平均负载和阈值相比较。当检测到平均负载连续多次(默认值为10)超出阈值范围时产生该告警。
平滑次数为1,平均负载小于或等于阈值时,告警恢复;平滑次数大于1,平均负载小于或等于阈值的90%时,告警恢复。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
12192 |
重要 |
物理资源告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群或系统名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
|
附加信息 |
触发条件 |
告警触发的条件。 |
对系统的影响
- 业务延迟:主机平均负载过高时,可能会导致业务进程运行处理缓慢、业务延迟。
- 业务失败:主机平均负载过高时,可能会导致业务处理缓慢、超时、失败,可能会导致作业运行失败。
可能原因
- 告警阈值配置或者平滑次数配置不合理。
- 主机配置无法满足业务需求,平均负载达到上限。或业务处于高峰期,导致短期内平均负载达到上限。
处理步骤
检查告警阈值配置或者平滑次数配置是否合理。
- 根据实际CPU使用情况,修改告警阈值和平滑次数配置项。
- 登录FusionInsight Manager,选择“运维 > 告警 > 阈值设置 > 待操作集群的名称 > 主机 > 主机状态> 平均负载”。
- 根据实际服务的使用情况,单击“平滑次数”后的编辑按钮,更改告警的平滑次数。
该选项的含义为告警检查阶段,“平滑次数”为连续检查多少次超过阈值,则发送告警。
- 单击规则“操作”列的“修改”,根据实际情况更改告警阈值。
- 等待2分钟,查看告警是否自动恢复。
- 是,处理完毕。
- 否,执行3。
检查平均负载是否达到上限。
- 在FusionInsight Manager页面,选择“运维 > 告警 > 告警”,在告警列表中展开此告警的详细信息,在定位信息中单击产生该告警的主机名称。
- 在主机的概览界面观察“平均负载”实时数据5分钟左右,若平均负载多次超过设置的阈值,请联系MRS集群管理员提升主机配置。
如果无“平均负载”图表,可单击右侧下拉三角,选择“定制”并勾选对应项,单击“确定”。
- 排查当前业务量是否处于高峰阶段。若处于高峰阶段导致该告警,建议对节点进行扩容,或者联系MRS集群管理员提升主机配置。
- 检查该告警是否恢复。
- 是,处理完毕。
- 否,执行7。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考