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云空间服务 KooDrive

删除对象失败

更新时间:2024-10-15 GMT+08:00

问题描述

无法删除已上传的OBS对象。

排查思路

以下排查思路根据原因的出现概率进行排序,建议您从高频率原因往低频率原因排查,从而帮助您快速找到问题根因。

如果处理完某个可能原因仍未解决问题,请继续排查其他可能原因。

表1 排查思路

可能原因

处理措施

本地网络故障

检查本地与OBS之间的网络是否正常,如果存在网络故障,解决网络故障,确保网络正常。

无删除对象的权限

请参考检查是否有删除对象的权限

对象所属桶已启用多版本控制

请参考在“已删除对象”列表彻底删除对象

“已删除对象”页签中WORM对象的保留策略在保留期内

请参考彻底删除保留策略在保留期内的WORM对象

删除的是文件夹,文件夹中的对象较多

请参考删除对象较多的文件夹

其他原因

请参考提交工单

检查是否有删除对象的权限

删除对象时报错“您没有执行此操作的权限。请联系您的管理员开通权限。”

  1. 确认桶ACLs是否有删除桶内对象的权限。
    1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
    2. 在左侧导航栏单击“访问权限控制 > 桶ACLs”,进入“桶ACLs”页面。
    3. 查看对应用户类型的桶访问权限下是否展示“写入权限”。
      图1 查看写入权限的展示状态
      • 如果已展示“写入权限”,此时仍然无法删除对象,请继续步骤3
      • 如果未展示“写入权限”,此时请继续步骤2
  2. 给对应类型的用户添加写入权限。
    1. 单击右边的“编辑”操作。
    2. 在弹窗内勾选“桶访问权限 > 写入权限”。
    3. 单击“确定”。
      图2 添加写入权限
  3. 联系桶拥有者,确认桶策略是否已授予DeleteObject(删除对象)或DeleteObjectVersion(删除特定版本的对象)权限。
    • 如果未授予上述权限,请联系桶拥有者授权。
    • 如果已授予上述权限,仍然无法删除对象,请提交工单寻求更多帮助。

在“已删除对象”列表彻底删除对象

说明:

对象所属桶已启用多版本控制时,在“对象”列表删除对象,对象会迁移至“已删除对象”列表中,需要彻底删除避免产生计费。

如果待彻底删除的对象为保留策略在保留期内的WORM对象,请参考彻底删除保留策略在保留期内的WORM对象处理。

  1. 确认对象所属桶是否启用多版本控制。
    1. 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
    2. 在左侧导航栏单击“概览”,进入“概览”页面。
    3. 在“基础配置”区域查看“多版本控制”状态。
      图3 查看多版本控制的状态
      • 如果状态为已启用,此时请继续下一步。
      • 如果状态为暂停或未启用,此时仍然无法删除对象,请提交工单寻求更多帮助。
  2. 彻底删除对象。
    1. 单击“已删除对象”页签,进入已删除对象列表。
    2. 在待删除对象的操作列单击“彻底删除”。
    3. 单击“确定”。
      图4 彻底删除对象

彻底删除保留策略在保留期内的WORM对象

在“已删除对象”页签中,待彻底删除的对象为保留策略在保留期内的WORM对象,请等待保留策略过期,即可删除对象。删除操作请参见手动彻底删除WORM对象配置生命周期规则删除WORM对象

查看WORM对象保留期状态方式:进入“对象详情 > 版本”页签,找到当前版本对象,单击“更多 > 延长保留期”,即可参考下文查看保留期状态。

图5 WORM对象的保留策略在保留期内
图6 WORM对象的保留策略已过期
图7 WORM对象未配置保留策略

删除对象较多的文件夹

在OBS控制台删除文件夹失败,可能是由于文件夹中的对象较多或目录层级较深。OBS控制台删除对象的机制是先列举对象,然后再执行删除操作,如果对象较多或目录层级较深,可能会因超时而删除失败。建议您使用obsutil工具来删除包含对象较多或目录层级较深的文件夹。具体请参见删除对象

提交工单

如果上述方法均不能解决您的疑问,请提交工单联系华为云客服为您解答。

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