更新时间:2025-11-03 GMT+08:00
文件系统挂载超时
现象描述
使用mount命令挂载文件系统到云服务器,云服务器系统提示“timed out”。
可能原因
- 原因1:网络状态不稳定。
- 原因2:网络连接异常。
- 原因3:DNS配置错误,导致解析不到文件系统的域名,挂载失败。
- 原因4:挂载的是Ubuntu18及以后版本的操作系统的云服务器。
定位思路
排除网络问题后,重试挂载命令。
解决方法
- 原因1和原因2:网络状态不稳定;网络连接异常。
- 成功=>处理结束。
- 失败=>原因3。
- 原因3:DNS配置错误,导致解析不到文件系统的域名,挂载失败。
- 确认租户DNS的配置,执行cat /etc/resolv.conf命令。
- 如果没有配置DNS,需配置DNS。配置DNS请参见。
- 如果配置了DNS,需确认DNS的正确性,执行如下命令:
如果解析出来的IP地址是100网段的,那么DNS配置正确,如果是其他网段的,那么DNS配置不正确。=>2
- 在修改配置文件“/etc/resolv.conf”配置正确的租户DNS,执行vi /etc/resolv.conf命令编辑“/etc/resolv.conf”文件。在已有的nameserver配置前写入DNS服务器的IP地址。
图1 配置DNS
格式如下:
- 单击“Esc”,并输入:wq,保存退出。
- 由于用户申请的的默认DNS是从其所在的VPC继承过来的,所以每当重启的时候,会从VPC同步DNS。所以只修改的配置,只能解决当前问题。根本的解决问题,还需要在VPC中修改。在所在的VPC的子网中设置正确的租户DNS。
- (可选)重新启动。
- 重新执行挂载。
- 成功=>处理结束。
- 失败=>。
- 确认租户DNS的配置,执行cat /etc/resolv.conf命令。
- 原因4:挂载的是Ubuntu18及以后版本的操作系统的云服务器。
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