更新时间:2024-06-25 GMT+08:00
无法查询LTS原始日志页面新产生的日志怎么办?
问题现象
在原始日志页面无法查询新产生的日志。
对系统的影响
导致用户无法查询业务日志。
可能原因
- 日志采集开关未开启。
- 日志是否发送失败。
- LTS下发的采集配置异常,覆盖了正确的采集配置。
排查方法
- 确认日志采集开关是否开启。
- 检查最近一次下发的日志采集开关配置。
- 登录ICAgent所在的ecs主机。
- 执行“cd /var/ICAgent”进入ICAgent日志目录。
- 执行如下命令,查询日志采集配置。
zgrep switchList *.zip //查询已转储日志压缩包 cat oss.icAgent.trace | grep switchList //查询当前日志文件
从过滤结果查找日志时间最新的配置,并查看switch.log是否为true(代表开启日志采集开关)。
- 检查日志采集开关文件的内容switch.log是否为true(代表开启日志采集开关)。
- 登录ICAgent所在的主机。
- 查询日志采集开关文件。
cat /var/share/oss/manager/ICProbeAgent/internal/TRACE_CONFIG/swithes_context.json
日志采集开关文件的内容switch.log为true。
- 确认是否日志发送失败。
- 登录ICAgent所在ecs主机。
- 执行“cd /var/ICAgent”进入ICAgent日志目录。
- 查询发送失败日志。
cat oss.icAgent.trace | grep httpsend | grep 'dataType:TRACE' | grep failed zgrep 'dataType:TRACE' *.zip | grep httpsend | grep failed
若显示failed代表日志发送失败,则需要联系LTS技术支持工程师排查。
- 确认LTS下发配置。
- 登录ICAgent所在ecs主机。
- 执行“cd /var/ICAgent”进入ICAgent日志目录。
- 过滤日志文件查询LTS下发的日志采集配置。
cat oss.icAgent.trace | grep 'als event' | grep -v grep | tail -n 1
以上截图仅供参考,请以实际查询结果为准。从过滤结果查找用户实际设置的日志组、日志流以及采集路径,则确保已下发采集配置。
- 如果日志文件查询不到,则查询日志压缩包。
zgrep 'als event' *.zip | grep -v grep | tail -n 1
- 登录云日志服务LTS控制台,确认是否正确下发了采集配置。
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