更新时间:2022-11-30 GMT+08:00
应用运维异常,调用程序失败怎么办?
应用发布程序启动路径配置错误
问题现象
用户配置完成应用发布资源后,通过云堡垒机首次访问应用发布资源,不能正常访问。
可能原因
- 原因一:应用程序启动路径配置错误。
- 原因二:配置应用程序非云堡垒机默认支持的应用程序,不支持调用。
解决办法
- 修改“程序启动路径”配置
- 登录云堡垒机系统,在应用服务器详情页面,查看配置的应用“程序启动路径”。
- 登录Windows应用服务器,查询应用安装路径,获取程序exe启动路径。
- 对比路径是否一致。若不一致,则需修改配置的“程序启动路径”。
- 重新安装支持的应用程序
- 登录Windows应用服务器,安装云堡垒机支持调用的应用,详情请参见使用限制。
- 登录云堡垒机系统,重新配置应用服务器“程序启动路径”。
Windows主机重启后,无法调用应用程序
问题现象
Windows应用服务器系统升级前,可以正常访问应用发布资源。系统升级重启后,访问应用发布资源被拒绝,无法调用配置的应用程序,提示“无法启用此初始程序”错误。
可能原因
Windows病毒和威胁防护更新后,对执行程序进行病毒检查时,Windows Defender会禁止启用所有名称中含有“administrator”字样的exe程序,例如默认支持的数据库应用程序“mysqladministrator.exe”。
解决办法
父主题: 登录资源故障
登录资源故障 所有常见问题
- 通过云堡垒机登录资源异常怎么办?
- 通过Web浏览器登录资源,报Code:T_514错误怎么办?
- 通过Web浏览器登录资源,报Code:T_1006错误怎么办?
- 通过Web浏览器登录资源,报Code:C_515错误怎么办?
- 通过Web浏览器登录资源,报Code:C_519错误怎么办?
- 通过Web浏览器登录主机资源,报Code:C_769错误怎么办?
- 运维资源列表可登录资源不可见怎么办?
- 通过Web浏览器登录资源,不弹出会话界面怎么办?
- 应用运维异常,调用程序失败怎么办?
- SSO工具异常,不能登录数据库资源怎么办?
- 通过堡垒机登录服务器资源,报“并发会话超出许可限制”怎么办?
- 如何解决“mstsc客户端访问服务器资源时鼠标出现黑块”的问题?
more