文档首页> 云堡垒机 CBH> 常见问题> 故障排除> 运维故障> 登录云堡垒机实例时,收不到短信验证码怎么办?
更新时间:2024-04-24 GMT+08:00

登录云堡垒机实例时,收不到短信验证码怎么办?

问题现象

  • 配置“手机短信”方式多因子登录后,通过手机短信方式登录,不能获取手机验证码,提示“发送短信失败!”
  • 重置登录密码,收不到短信验证码。

可能原因

  • 原因一:受浏览器兼容性限制,当浏览器版本与云堡垒机系统不匹配时,会导致不能获取到短信验证码,甚至登录后页面显示异常和无法操作。
  • 原因二:安全组限制了短信网关IP,或未放开10743、443端口。
  • 原因三:用户手机号码配置错误。
  • 原因四:用户手机短信业务有异常。
  • 原因五:堡垒机实例未绑定弹性公网IP(Elastic IP,EIP)。

解决办法

  • 原因一:
    更换浏览器或升级浏览器版本,通过Web登录推荐使用浏览器及版本请参见表1
    表1 推荐浏览器及版本

    浏览器

    版本

    Edge

    44及以上版本

    Chrome

    52.0及以上版本

    Safari

    10及以上版本

    Firefox

    50.0及以上版本

  • 原因二:

    云堡垒机实例绑定的安全组放开短信网关IP和10743、443端口。

  • 原因三:

    普通用户请联系管理员,修改绑定的手机号码。

    admin用户配置了手机短信登录,但手机号码配置错误,请直接联系技术支持。

  • 原因四:

    用户确认绑定手机的短信业务状态,请从以下几个方面分别确认:

    • 确认手机是否欠费停机。
    • 确认验证短信是否被拦截归为垃圾短信。
    • 确认手机网络通讯是否正常。
  • 原因五:

    用户若需登录云堡垒机系统,必须首先为实例绑定弹性IP。为满足CBH使用需求,建议配置EIP带宽为5M以上。