修改参数配置
功能介绍
Elasticsearch集群的核心配置信息都集中在“elasticsearch.yml”和“kibana.yml”文件中,OpenSearch集群的核心配置信息都集中在“opensearch.yml”和“opensearch_dashboards.yml”文件中。当需要根据业务需求调整集群的运行行为时,比如优化查询速度、修改跨域访问配置、调整内部缓存大小或管理后台任务队列等,则可以通过修改参数配置实现。
在使用该接口之前,建议先调用获取参数配置列表,确认集群的参数配置情况,便于根据需求修改参数配置。
接口约束
自定义参数需要配置为Elasticsearch支持的参数,否则集群重启会失败,建议谨慎操作,以免影响业务。
调用方法
请参见如何调用API。
URI
POST /v1.0/{project_id}/clusters/{cluster_id}/ymls/update
请求参数
| 参数 | 是否必选 | 参数类型 | 描述 |
|---|---|---|---|
| edit | 是 | UpdateYmlsReqEdit object | 参数解释: 配置文件信息。 约束限制: 不涉及 |
| inst_type | 否 | String | 参数解释: 节点类型。 约束限制: KooSearch集群涉及不同类型的节点,其他类型集群不涉及。 取值范围: 默认取值: 不涉及 |
| 参数 | 是否必选 | 参数类型 | 描述 |
|---|---|---|---|
| modify | 否 | UpdateYmlsReqEditModify object | 参数解释: 修改参数配置的操作。 约束限制: |
| delete | 否 | UpdateYmlsReqEditModify object | 参数解释: 删除自定义参数配置的操作。 约束限制: |
| reset | 否 | UpdateYmlsReqEditModify object | 参数解释: 重置参数配置的操作。 约束限制: |
响应参数
状态码:200
请求示例
-
POST https://{Endpoint}/v1.0/{project_id}/clusters/4f3deec3-efa8-4598-bf91-560aad1377a3/ymls/update { "edit" : { "modify" : { "elasticsearch.yml" : { "thread_pool.force_merge.size" : 1 } } } } -
POST https://{Endpoint}/v1.0/{project_id}/clusters/4f3deec3-efa8-4598-bf91-560aad1377a3/ymls/update { "edit" : { "delete" : { "elasticsearch.yml" : { "thread_pool.force_merge.size" : 1 } } } } -
POST https://{Endpoint}/v1.0/{project_id}/clusters/4f3deec3-efa8-4598-bf91-560aad1377a3/ymls/update { "edit" : { "reset" : { "elasticsearch.yml" : { "http.cors.allow-credentials" : "false" } } } }
响应示例
状态码:200
请求成功。
{
"acknowledged" : true,
"externalMessage" : null,
"httpErrorResponse" : null
} 状态码
| 状态码 | 描述 |
|---|---|
| 200 | 请求成功。 |
| 400 | 非法请求。 建议直接修改该请求,不要重试该请求。 |
| 409 | 服务器在完成请求时发生冲突。 返回该状态码,表明客户端尝试创建的资源已经存在,或者由于冲突请求的更新操作不能被完成。 |
| 412 | 未满足前提条件,服务器未满足请求者在请求中设置的其中一个前提条件。 |
错误码
请参见错误码。