更新时间:2023-03-17 GMT+08:00

ALM-16047 HiveServer已从Zookeeper注销

告警解释

系统每60秒周期性检测Hive服务,若Hive在Zookeeper上的注册信息丢失,或者Hive无法连接上Zookeeper,将会发出告警。

告警属性

告警ID

告警级别

是否自动清除

16047

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

当无法在Zookeeper上读取到Hive的配置,将会导致HiveServer不可用。

可能原因

  • 网络故障。
  • ZooKeeper实例状态异常。

处理步骤

重启相关实例

  1. 登录FusionInsight Manager,在FusionInsight Manager首页,选择“运维 > 告警 > 告警”,单击告警“Hive解注Zookeeper”所在行的下拉菜单,在“定位信息”中查看告警上报的角色名并确定实例IP地址。
  2. 选择“集群 > 待操作集群的名称 > 服务 > Hive > 实例”,勾选上报告警IP对应的实例,选择“更多 > 重启实例”。
  3. 重启完成后,等待5分钟,查看告警是否消除。

    • 是,处理完毕。
    • 否,执行4

收集故障信息。

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Hive”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。