ALM-16000 Percentage of Sessions Connected to the HiveServer to the Maximum Number Allowed Exceeds the Threshold (For MRS 2.x or Earlier)
Description
The system checks the percentage of sessions connected to the HiveServer to the maximum number allowed every 30 seconds. This indicator can be viewed on the Hive service monitoring page. This alarm is generated when the the percentage of sessions connected to the HiveServer to the maximum number allowed exceeds the specified threshold (90% by default).
This alarm can be automatically cleared when the percentage is less than or equal to the threshold.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
16000 |
Major |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger condition |
Generates an alarm when the actual indicator value exceeds the specified threshold. |
Impact on the System
If a connection alarm is generated, too many sessions are connected to the HiveServer and new connections cannot be created.
Possible Causes
Too many clients are connected to the HiveServer.
Procedure
- Increase the maximum number of connections to Hive.
- Go to the MRS cluster details page and click Components.
- Choose Hive > Service Configuration and switch Basic to All.
- Increase the value of the hive.server.session.control.maxconnections configuration item. Suppose the value of the configuration item is A, the threshold is B, and sessions connected to the HiveServer is C. Adjust the value of the configuration item according to A x B > C. Sessions connected to the HiveServer can be viewed on the Hive monitoring page.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 2.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Reference
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot