Help Center/ Web Application Firewall/ Troubleshooting/ Troubleshooting Website Connection Exceptions/ Why Does the Requested Page Respond Slowly After My Website Is Connected to WAF?
Updated on 2024-10-23 GMT+08:00

Why Does the Requested Page Respond Slowly After My Website Is Connected to WAF?

Symptom

After a website is connected to WAF, the website becomes slow.

Possible Causes

You may have configured forcible redirection from HTTP to HTTPS at the backend of the server but enabled only forwarding from HTTPS (client protocol) to HTTP (origin server protocol) on WAF. This makes WAF redirects requests, which leads to an infinite loop.

Solution

To address this issue, add HTTP-to-HTTP and HTTPS-to-HTTPS forwarding rules. The procedure is as follows:

  1. Log in to the WAF console.
  2. In the navigation pane on the left, choose Website Settings.
  3. In the domain name list, click the target domain name.
  4. In the Origin Servers area, click Edit.
  5. In the Edit Server Information dialog box, add two forwarding rules, one for HTTP to HTTP and the other for HTTPS to HTTPS.

    Figure 1 Example configuration

For details about how to configure a forwarding rule, see Why Was My Website Redirected So Many Times?