Help Center/ Scalable File Service Turbo/ Troubleshooting/ Writing to a File System Failed
Updated on 2024-11-06 GMT+08:00

Writing to a File System Failed

Symptom

Data failed to be written to the file system mounted to ECSs running the same type of OS.

Possible Causes

The ECS security group configuration is incorrect. Specifically, the port used to communicate with the file system is not enabled.

Fault Diagnosis

Check whether the port of the ECS is enabled and correctly configure the port on the security group console.

Solution

  1. Log in to the ECS console.

    1. Log in to the console.
    2. Click in the upper left corner and select a region.
    3. Choose Service List > Compute > Elastic Cloud Server.

  2. On the displayed page, select the target ECS to go to the ECS details page.
  3. Click the Security Groups tab and select the target security group. Click Manage Rule to go to the security group console.
  4. On the displayed page, click the Inbound Rules tab and click Add Rule to open the Add Inbound Rule page, as shown in Figure 1. Add rules as follows:

    After an SFS Turbo file system is created, the system automatically enables the security group ports required by NFS. This ensures that the SFS Turbo file system can be successfully mounted to the ECSs. The inbound ports required by NFS are ports 111, 2049, 2051, 2052, and 20048. If you need to change the enabled ports, go to the VPC console, choose Access Control > Security Groups, locate the target security group, and change the ports.

    You are advised to use an independent security group for an SFS Turbo file system to isolate it from service nodes.

    Figure 1 Add Inbound Rule

  5. Click OK. Access the file system again for verification.