ALM-50209 Failures to Generate Metadata Image Files Exceed the Threshold
Alarm Description
The system checks the number of failures to generate metadata image files on the FE node every 30 seconds. This alarm is generated when the number of failures exceeds the threshold (1 by default).
This alarm is cleared when the system detects that the number of failures is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
50209 |
Critical |
Error handling |
Doris |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Detail |
Specifies the alarm triggering condition. |
Impact on the System
The non-master FE node cannot receive the latest metadata image file. As a result, the system reliability deteriorates.
Possible Causes
When the checkpoint thread of the Doris FE detects that the FE memory usage exceeds 75%, the thread determines that the write operation to the image file fails.
Handling Procedure
Check the Doris service status.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. In the alarm list, view the role name and obtain the IP address of the instance in Location of the alarm whose ID is 50209.
- Choose Cluster > Services > Doris > Instances, click the FE instance for which the alarm is generated, and click the Chart tab of the instance.
Select CPU and Memory from the chart categories on the left, and check whether the value of Memory Usage of FE exceeds 75%.
- Choose Cluster > Service > Doris, and click the Configurations tab. Search for the FE_GC_OPTS parameter, and increase the value of -Xmx. The default value is 8 GB.
- If this alarm is occasionally generated, increase the value by 0.5 times. If this alarm is frequently generated, double the value.
- In the case of large service volume and high service concurrency, you are advised to add instances.
- Click Save. Click Instances, select an FE instance whose configuration has expired, and choose More > Restart Instance.
- After restart, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, select Doris for the target cluster, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
You need to manually clear the alarm after the fault is rectified.
Related Information
None.
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