ALM-43605 Number of Real-Time Requests on a GraphBase Node Exceeds the Threshold
Alarm Description
The system checks the status of GraphBase service every 60 seconds. This alarm is generated when the number of query requests to the GraphBase client exceeds the configured threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
43605 |
Major |
Quality of service |
GraphBase |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- Too many connections are maintained for the requests and the network resources are limited. As a result, the communications between services may be abnormal.
- The GraphBase service may be unavailable.
Possible Causes
- The client is requested too frequently.
- The threshold is too low.
Handling Procedure
Check the number of real-time requests on the GraphServer node.
- On FusionInsight Manager, click O&M, and choose Alarm > Thresholds in the navigation pane on the left. Click the name of the desired cluster > GraphBase and view the threshold of GraphServer Real-Time Requests.
- On FusionInsight Manager, choose O&M > Alarm > Alarms and select the alarm whose ID is 43605. Check the role name and the IP address of the host where the alarm is generated in Location.
- On the FusionInsight Manager homepage, choose Cluster > Name of the desired cluster > Service > GraphBase > Instance. Click the GraphServer where the alarm is reported. On the dashboard page that is displayed, expand the drop-down list box in the upper right corner of the graph area, choose Customize > GraphServer Real-Time Requests, and click OK to check whether the number of the requests exceeds the threshold.
- On FusionInsight Manager, click O&M, and choose Alarm > Thresholds in the navigation pane on the left. Click the name of the desired cluster > GraphBase and reset the threshold of GraphServer Real-Time Requests.
- Wait for one minute and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
- Stop sending any requests for creating, deleting, updating, or querying relationships.
Wait for one minute and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 7.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select GraphBase for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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