Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-19023 Region Traffic Restriction for HBase
Updated on 2024-11-29 GMT+08:00

ALM-19023 Region Traffic Restriction for HBase

Alarm Description

When the MetricController instance is installed for the HBase service, self-healing from hotspotting is automatically enabled. The alarm module checks whether there are regions whose request traffic is restricted due to hotspot issues in HBase every 120 seconds. This alarm is generated when the region where hotspot traffic is restricted is detected in HBase.

This alarm is cleared when the region is no longer a hotspot.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

19023

Critical

Quality of service

HBase

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Additional Information

Hot Regions

Name of the region where the request traffic is restricted due to hotspotting.

Impact on the System

If the traffic of a hotspot region is restricted, the number of handlers for processing the requests in the region is limited. As a result, services requesting the region may slow down or retry upon failure.

Possible Causes

Too many requests are directed to a single region when the HBase service is accessed.

Handling Procedure

Check whether there are too many requests in a single region of HBase.

  1. Log in to FusionInsight Manager, and Choose O&M > Alarm > Alarms.
  2. In Additional Information of Region Traffic Restriction for HBase, view the reported table name and region information.
  3. On FusionInsight Manager, choose Cluster > Service > HBase and click the hyperlink on the right of HMaster web UI.
  4. Click Table Details and adjust service configurations in the region where the table in 2 is deployed.
  5. Wait a moment and then check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select HBase for the target cluster.
  3. In the Host area, select the host where the HMaster instance is deployed.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm will be automatically cleared.

Related Information

None.