Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-12068 Abnormal ACS Resources of Manager
Updated on 2024-11-29 GMT+08:00

ALM-12068 Abnormal ACS Resources of Manager

Alarm Description

HA checks the ACS resources of Manager every 80 seconds. This alarm is generated when HA detects that the ACS resources are abnormal for two consecutive times.

This alarm is cleared when HA detects that the ACS resources are normal.

Resource Type of ACS is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new ACS resources have been enabled on the new active Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby Manager switchover.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

12068

Major

Quality of service

FusionInsight Manager

Yes

Alarm Changes

Change Type

Version

Description

Reason for Change

Modify

3.3.1

Alarm Name: changed from "ACS Resource Is Abnormal" to "Abnormal ACS Resources of Manager".

Alarm Name: Standardized

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

An active/standby Manager switchover may occur. The security authentication and user management functions cannot be provided for ACS upper-layer applications. As a result, you may fail to log in to Manager and component web UIs.

Possible Causes

The ACS process is abnormal.

Handling Procedure

Check whether the ACS process is normal.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the name of the host for which the alarm is generated.
  2. Log in to the host for which the alarm is generated as user root.
  3. Run the su - omm command and then sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh to check whether the status of the ACS resources managed by the HA is normal. In the single-node system, the ACS resource is in the normal state. In the dual-node system, the ACS resource is in the normal state on the active node and in the stopped state on the standby node.

    • If yes, go to 6.
    • If no, go to 4.

  4. Run the vi ${BIGDATA_LOG_HOME}/omm/oms/ha/scriptlog/acs.log command to check whether the ACS resource log of HA contains the keyword ERROR. If yes, analyze the logs to locate the resource exception cause and fix the exception.
  5. After 5 minutes, check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. In the Services area, select Controller and OmmServer, and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.