Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-12028 Number of Processes in the D State on a Host Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-12028 Number of Processes in the D State on a Host Exceeds the Threshold

Alarm Description

The system checks the number of processes in the D state of user omm on the host every 30 seconds and compares the actual number with the threshold. The number of processes in the D state on the host has a default threshold range. This alarm is generated when the number of processes exceeds the threshold.

This alarm is cleared when the Trigger Count is 1 and the total number of processes in the D state of user omm on the host does not exceed the threshold. This alarm is cleared when the Trigger Count is greater than 1 and the total number of processes in the D state of user omm on the host is less than or equal to 90% of the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

12028

Major

Environment

FusionInsight Manager

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Trigger condition

Specifies the alarm triggering condition.

Impact on the System

  • Latency: New service processes cannot be created. Concurrent task processing may be slow and services may be delayed.
  • Service failure: New service processes cannot be created, which may cause job failures.

Possible Causes

The host responds slowly to I/O (disk I/O and network I/O) requests and some processes are in the D state and Z state.

Handling Procedure

Check the processes in the D state.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the IP address of the host for which the alarm is generated.
  2. Log in to the host for which the alarm is generated as user root. () Then run the su - omm command to switch to user omm.
  3. Run the following command as user omm to view the PID of the process that is in the D state:

    ps -elf | grep -v "\[thread_checkio\]" | awk 'NR!=1 {print $2, $3, $4}' | grep omm | awk -F' ' '{print $1, $3}' | grep -E "Z|D" | awk '{print $2}'

  4. Check whether the command output is empty.

    • If yes, the service process is running properly. Then go to 6.
    • If no, go to 5.

  5. Switch to user root and run the reboot command to restart the host for which the alarm is generated. (Restarting a host is risky. Ensure that the service process is normal after the restart.)
  6. Check whether the alarm is cleared 5 minutes later.

    • If yes, no further action is required.
    • If no, go to 7.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M > Log > Download.
  2. Select OMS for Service and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.