Help Center/ Storage Disaster Recovery Service/ FAQs/ Asynchronous Replication/ How Do I Handle the drm Process Start Failure?
Updated on 2024-11-27 GMT+08:00

How Do I Handle the drm Process Start Failure?

Symptom

The drm process failed to start after the disaster recovery gateway is deployed or proxy client is installed.

Possible Causes

Possible causes are as follows:

  • Cause 1: The service account does not have the write permission on the /dev/null directory.
  • Cause 2: The server cannot resolve the hostname domain name.

Solution 1

Assign the read and write permissions on the /dev/null directory to the service account.

  1. Log in to the server where the disaster recovery gateway or proxy client resides.
  2. Run the following command as user root to change the permission on the /dev/null directory:

    chmod 666 /dev/null

  3. Run the following command to check the permission on the /dev/null directory:

    ll /dev/null

    The permission is successfully changed if information similar to the following is displayed:
    crw-rw-rw- 1 root root 1, 3 Apr  9 09:21 /dev/null

Solution 2

Add the domain name resolution of hostname.

  1. Log in to the server where the disaster recovery gateway or proxy client resides.
  2. Run the following command as user root to add the domain name resolution of hostname:

    echo "127.0.0.1 `hostname`" >> /etc/hosts

  3. Run the following command to check whether the domain name resolution of hostname takes effect:

    ping `hostname`

    The configuration is successful if information similar to the following is displayed:
    PING test-dr (127.0.0.1) 56(84) bytes of data.64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.022 ms