Help Center/ Resource Governance Center/ FAQs/ What Should I Do When an Account Failed to Be Enrolled?
Updated on 2025-02-20 GMT+08:00

What Should I Do When an Account Failed to Be Enrolled?

Symptom

An error is reported during the enrollment of an account that was invited to an organization.

Possible Causes

The account invited to the organization does not have an agency.

Solution

  1. Log in to Huawei Cloud using the account you want to enroll, and navigate to the IAM console.
  2. In the navigation pane, choose Agencies and click Create Agency in the upper right corner.

    Figure 1 Creating an agency

  3. Set the agency name to RGCServiceExecutionAgency.

    Figure 2 Specifying an agency name

  4. Set Agency Type to Account and Delegated Account to the RGC management account name.
  5. Configure a validity period and enter a description for the agency.
  6. Click OK.
  7. In the displayed dialog box, click Authorize.
  8. Select Security Administrator, FullAccess, and Tenant Guest.

    Figure 3 Permissions to be granted to the agency

  9. Click Next to set the authentication scope.
  10. Click OK. The agency is created. The RGC management account can then enroll the account on the RGC console by referring to Enrolling an Account.

    Once the RGCServiceExecutionAgency agency is created, it cannot be deleted; otherwise, RGC services will become unavailable.