Help Center/ Identity and Access Management_Identity and Access Management (New Edition)/ FAQs/ Security Settings/ What Can I Do If the System Displays a Message Indicating that the MFA Device Already Exists When I Attempt to Add It?
Updated on 2025-11-06 GMT+08:00

What Can I Do If the System Displays a Message Indicating that the MFA Device Already Exists When I Attempt to Add It?

Symptom

On the new IAM console, you can choose Users in the left navigation pane and click Security Settings in the Operation column of the row containing the target user. In the Multi-Factor Authentication (MFA) area, click Add MFA Device, enter the device name, and click Next. Then the message Virtual MFA device already exists. is displayed.

Cause

  • An MFA device has already been bound to the user. Each user can only have one MFA device bound.
  • The virtual MFA device with the same name has been bound to another user in the account. The virtual MFA device name must be unique in the account.

Solution

On the new IAM console, choose Users > Security Settings. In the Multi-Factor Authentication (MFA) area, check whether an MFA device has been bound to the user or whether an MFA device with the same name has been bound to another user in the account.