Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?
Symptom
org.apache.flink.shaded.curator.org.apache.curator.ConnectionState - Authentication failed
Possible Causes
Service authorization is not configured for the account on the Global Configuration page. When the account is used to create a datasource connection to access external data, the access fails.
Solution
- Log in to the DLI management console. In the navigation pane on the left, choose Global Configuration > Service Authorization.
- On the agency settings page, select required permissions.
DLI Datasource Connections Agency Access is the permissions to access and use VPCs, subnets, routes, and VPC peering connections in datasource scenarios.
For more information, see DLI Agency Permissions.
- Select the permissions to be included in dli_management_agency and click Update.
Figure 1 Updating agency permissions
- After updating the agency, recreate the datasource connection and rerun the job.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot