Help Center/ Data Lake Insight/ FAQs/ Flink Jobs/ Flink Job Performance Tuning/ What Should I Do If a Flink Job Fails to Submit As It Has Not Been Assigned an IP Address Due to a Shortage of IP Addresses in the CIDR Block of the Queue?
Updated on 2024-11-15 GMT+08:00

What Should I Do If a Flink Job Fails to Submit As It Has Not Been Assigned an IP Address Due to a Shortage of IP Addresses in the CIDR Block of the Queue?

Symptom

When submitting jobs using Flink 1.12 and Flink 1.15, there is an issue where there are not enough IP addresses in the queue CIDR block to allocate IP addresses for compute resources, causing the Flink job submission to fail. Despite having sufficient resources, there are no available IP addresses.

Possible Causes

Apache Flink supports two job submission modes: Application Mode and Session Mode. Both modes may encounter issues where Flink job submission fails due to the inability to allocate IP addresses.

Solution

To resolve the issue of Flink job submission failure due to insufficient IP addresses, the following configurations can be added to the job optimization parameters:

  • Enable HostNetwork.
    kubernetes.dli.hostnetwork.enabled=true
    kubernetes.hostnetwork.enabled=true
  • Adjust the leader election configuration.
    high-availability.kubernetes.leader-election.renew-deadline=15s
    high-availability.kubernetes.leader-election.lease-duration=15s