Help Center/ Data Lake Insight/ FAQs/ DLI Permissions Management/ How Do I Do If I Receive an Error Message Stating That I Do Not Have Sufficient Permissions When Creating a Table After Upgrading the Engine Version of a Queue?
Updated on 2024-11-15 GMT+08:00

How Do I Do If I Receive an Error Message Stating That I Do Not Have Sufficient Permissions When Creating a Table After Upgrading the Engine Version of a Queue?

Symptom

After upgrading the queue version from Spark 2.x to Spark 3.3.x or switching to HetuEngine, I still receive an error message stating that I do not have sufficient permissions when trying to create a table, even though I have been granted table creation permissions.

Possible Causes

The authorization methods supported may differ depending on the engine version of the DLI queue.

HetuEngine does not support IAM user authorization and requires resource authorization provided by the DLI console.

Solution

Grant users the permission to create tables by referring to Managing Database Permissions.